[Rubygems-developers] Recognizing Platforms

Steven Lumos steven at lumos.us
Fri Aug 24 18:56:31 EDT 2007


"Austin Ziegler" <halostatue at gmail.com> writes:
> On 8/21/07, Eric Hodel <drbrain at segment7.net> wrote:
>> I think Solaris 8 has the platform solaris2.8 and so-forth.  AFAIK, 8
>> and 9 aren't necessarily compatible the same way OpenBSD 4.0 and 4.1
>> aren't necessarily compatible.
>
> Sun guarantees forward compatibility for an architecture; something
> built on Solaris 8 will run on 9 and 10. Something built on 10 won't
> run on 8 or 9.
>
> -austin

Right.  In an emergency, I once brought up a 15-year-old version of
FrameMaker that was last used on SPARCStation 1s under SunOS 4.1
("Solaris 1") on my Blade 2500 (UltraSPARC IV, Solaris 8).  Including
flexLM.

Steve



More information about the Rubygems-developers mailing list