[Rubygems-developers] Source caches again.

Nick Sieger nicksieger at gmail.com
Thu Aug 23 18:48:42 EDT 2007


On 8/22/07, Hugh Sasse <hgs at dmu.ac.uk> wrote:
>
> I've obtained flog 1.1.0 from the repository on my cygwin system.
> If I try to get flog on solaris9, I get 1.0.2.  If I update, I still
> get 1.0.2.  If I get rid of anything like a source cache:
>
> brains# ls -l sourc*
> -rw-r--r--   1 root     other          4 Aug 22 14:15 source_cache
> -rw-r--r--   1 root     other    2261136 Feb  4  2005 source_caches
> brains# rm source_caches
> brains# rm source_cache
> brains# gem install flog '=1.1.0'
> Bulk updating Gem source index for: http://gems.rubyforge.org
> ERROR:  While executing gem ... (Gem::GemNotFoundException)
>     Could not find flog (> 0) in any repository
> brains# ls -ltr
> total 16
> drwxr-xr-x   2 root     other       1536 Aug 22 13:55 cache
> drwxr-xr-x   2 root     other       2048 Aug 22 13:55 specifications
> drwxr-xr-x  50 root     other       1536 Aug 22 13:55 gems
> drwxr-xr-x  37 root     other       1024 Aug 22 13:57 doc
> -rw-r--r--   1 root     other          4 Aug 22 14:23 source_cache
> brains# od source_cache
> 0000000 002010 075400
> 0000004
> brains#
>
> What do I need to do to get this working again?


Try "gem install flog" again.  There is a bug in the latest release that
prevents installing any gem when there is no source_cache.  Now that there
is at least a (near) empty file, it should work fine.

/Nick
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/rubygems-developers/attachments/20070823/2e8531ba/attachment.html 


More information about the Rubygems-developers mailing list