[Rubygems-developers] Potential enhancement

Wes Gamble weyus at att.net
Tue Sep 26 12:01:41 EDT 2006


I run "gem update" on my Win XP box, and although I've installed mongrel 
0.3.13.3 at least twice, it still shows up as something that needs to be 
updated.  I'm pretty sure it's because the update is looking at the 
_latest_ revision (0.3.13.4), which is only a Ruby install and sees that 
I have 0.3.13.3.

gem update should handle the case where a Windows client is present and 
look for the latest win32 package to be installed.  In fact, there 
should be a way to allow clients to use whichever version they want. 

The "skipping" gem update feature coming will give a way to handle this, 
but I just wanted to point it out.

Thanks,
Wes

=====================
C:\eclipse\workspace>gem list mongrel

*** LOCAL GEMS ***

mongrel (0.3.13.3)
    A small fast HTTP library and server that runs Rails, Camping, and
    Nitro apps.

mongrel_service (0.1)
    Mongrel Native Win32 Service Plugin for Rails

==========================
C:\eclipse\workspace>gem update
Updating installed gems...
Attempting remote update of mongrel
Select which gem to install for your platform (i386-mswin32)
 1. mongrel 0.3.13.4 (ruby)
 2. mongrel 0.3.13.3 (mswin32)
 3. mongrel 0.3.13.3 (ruby)
 4. mongrel 0.3.13.2 (ruby)
 5. mongrel 0.3.13.2 (mswin32)
 6. mongrel 0.3.13.1 (ruby)
 7. mongrel 0.3.13.1 (mswin32)
 8. mongrel 0.3.13 (ruby)
 9. mongrel 0.3.13 (mswin32)
 10. mongrel 0.3.12.4 (ruby)
 11. mongrel 0.3.12.4 (mswin32)
 12. mongrel 0.3.12.3 (ruby)
 13. mongrel 0.3.12.3 (mswin32)
 14. mongrel 0.3.12.2 (ruby)
 15. mongrel 0.3.12.2 (mswin32)
 16. mongrel 0.3.12.1 (ruby)
 17. mongrel 0.3.12.1 (mswin32)
 18. mongrel 0.3.12 (mswin32)
 19. mongrel 0.3.12 (ruby)
 20. mongrel 0.3.11 (ruby)
 21. mongrel 0.3.11 (mswin32)
 22. mongrel 0.3.10.1 (ruby)
 23. mongrel 0.3.10 (ruby)
 24. mongrel 0.3.9 (ruby)
 25. mongrel 0.3.8 (ruby)
 26. mongrel 0.3.8 (mswin32)
 27. mongrel 0.3.7.1 (ruby)
 28. mongrel 0.3.7.1 (mswin32)
 29. mongrel 0.3.7 (ruby)
 30. mongrel 0.3.6 (ruby)
 31. mongrel 0.3.6 (mswin32)
 32. mongrel 0.3.5 (ruby)
 33. mongrel 0.3.5 (mswin32)
 34. mongrel 0.3.4 (ruby)
 35. mongrel 0.3.4 (mswin32)
 36. mongrel 0.3.3 (ruby)
 37. mongrel 0.3.2 (ruby)
 38. mongrel 0.3.1 (ruby)
 39. mongrel 0.3 (ruby)
 40. mongrel 0.2.2 (ruby)
 41. mongrel 0.2.1 (ruby)
 42. mongrel 0.2.0 (ruby)
 43. Cancel installation
 >


More information about the Rubygems-developers mailing list