[Rubygems-developers] Can't install fxruby via rubygems 0.9.0 on Windows XP

Lyle Johnson lyle.johnson at gmail.com
Fri Sep 22 09:37:46 EDT 2006

On 9/21/06, Wes Gamble <weyus at att.net> wrote:

> I uninstalled fxruby using "gem uninstall" and attempted to reinstall
> using "gem install" and I still get the 404 error.
> 1) Is there a way for me to update the list of mirrors - I assume that
> that is all handled server-side so probably not.
> 2) Is there some debug mode that I can run gem install in, so that I can
> see which server and/or file is being looked for?

Per Tom Copeland, the problem wasn't that the file wasn't there; the
problem was that the RubyGems server code was looking for it under a
different file name. I will be filing a bug report about that, but in
the meantime I've renamed one of the Gem files so that the Gem server
will be able to serve it up.

The file "fxruby-1.6.2-mswin32.gem" should now be served-up properly
when you type:

    gem [install | update] fxruby

Note that this gem was built against Ruby 1.8.5, which has at least
one bug that impacts FXRuby. If you need a gem for FXRuby-1.6.2 that
was built against Ruby 1.8.4, you'll have to download the Gem file
directly from the FXRuby project page and install it locally.

Hope this helps,


More information about the Rubygems-developers mailing list