[Rubygems-developers] Can't install fxruby via rubygems 0.9.0 on Windows XP

Tom Copeland tom at infoether.com
Thu Sep 21 22:31:16 EDT 2006


On Thu, 2006-09-21 at 09:56 -0500, Lyle Johnson wrote:
> On 9/21/06, Tom Copeland <tom at infoether.com> wrote:
> 
> > Hm, both those win32 gems seem to be on all the mirrors:
> 
> <snip>
> 
> Yeah, the files are there. Is it a naming convention thing? What I
> mean is, is the fact that the gems are named:
> 
>     fxruby-1.4.7-ruby1.8.4-mswin32.gem
>     fxruby-1.4.7-ruby1.8.5-mswin32.gem
> 
> and:
> 
>     fxruby-1.6.2-ruby1.8.4-mswin32.gem
>     fxruby-1.6.2-ruby1.8.5-mswin32.gem
> 
> Causing the gem server code some grief?

Hm, maybe... I guess it depends on where the gem HTTP client expects to
find those dashes.  Ah ha... now that I check the logs, here's what's
being requested:

GET /gems/fxruby-1.6.2-mswin32.gem

That's why those 404 errors are popping up...

Yours,

Tom




More information about the Rubygems-developers mailing list