[Rubygems-developers] Can't install fxruby via rubygems 0.9.0 on Windows XP

Tom Copeland tom at infoether.com
Thu Sep 21 10:11:30 EDT 2006


Hm, both those win32 gems seem to be on all the mirrors:

================
# ./rubyforge_gem_updater.rb checkgem fxruby-1.6.2-ruby1.8.5-mswin32.gem
Checking fxruby-1.6.2-ruby1.8.5-mswin32.gem to see if it has propagated
Checking rubyforge.rubyuser.de... OK
Checking gems.rubyforge.vm.bytemark.co.uk... OK
Checking rubyforge.halostatue.info... OK
Checking rubyforge.iasi.roedu.net... OK

# ./rubyforge_gem_updater.rb checkgem fxruby-1.6.2-ruby1.8.4-mswin32.gem
Checking fxruby-1.6.2-ruby1.8.4-mswin32.gem to see if it has propagated
Checking rubyforge.rubyuser.de... OK
Checking gems.rubyforge.vm.bytemark.co.uk... OK
Checking rubyforge.halostatue.info... OK
Checking rubyforge.iasi.roedu.net... OK
================

Yours,

Tom



On Thu, 2006-09-21 at 09:05 -0500, Curt Hibbs wrote:
> I'm wondering if the problem is with one of the RubyForge mirrors
> being missing the file.
> 
> Tom, is there an easy way to check this?
> 
> Curt
> 
> On 9/18/06, Anatol Pomozov <anatol.pomozov at gmail.com> wrote:
>         The same problem for me.
>         
>         Seems this .gem file absent in repository.
>         
>         
>         On 9/19/06, Wes Gamble <weyus at att.net> wrote:
>                 I hate to bother this list with this issue, but I've
>                 been trying to do
>                 gem updates for several days now and I can't
>                 succesfully get the fxruby 
>                 gem to install.  See below.
>                 
>                 If I choose "2" to install the mswin32 fxruby, it
>                 fails with a 404.  If
>                 I choose "34" to cancel the installation, gem stops
>                 and I can't install
>                 anything else. 
>                 
>                 I thought I saw a post recently that showed some way
>                 to "skip" a
>                 particular gem.  Is that correct?  How would I do it?
>                 
>                 Also, is there any way to see which gems may depend on
>                 fxruby, 'cause I
>                 just want to uninstall it anyway :).
>                 
>                 Thanks,
>                 Wes
>                 
>                 ===============================================
>                 
>                 C:\eclipse\workspace>gem update
>                 Updating installed gems...
>                 Attempting remote update of fxruby 
>                 Select which gem to install for your platform
>                 (i386-mswin32)
>                 1. fxruby 1.6.2 (ruby)
>                 2. fxruby 1.6.2 (mswin32)
>                 3. fxruby 1.6.1 (ruby)
>                 4. fxruby 1.6.1 (mswin32)
>                 5. fxruby 1.6.0 (mswin32)
>                 6. fxruby 1.6.0 (ruby)
>                 7. fxruby 1.4.7 (mswin32)
>                 8. fxruby 1.4.7 (ruby)
>                 9. fxruby 1.4.6 (ruby)
>                 10. fxruby 1.4.6 (mswin32)
>                 11. fxruby 1.4.5 (ruby)
>                 12. fxruby 1.4.5 (mswin32)
>                 13. fxruby 1.4.4 (ruby)
>                 14. fxruby 1.4.4 (mswin32)
>                 15. fxruby 1.4.3 (mswin32)
>                 16. fxruby 1.4.3 (ruby)
>                 17. fxruby 1.4.2 (ruby)
>                 18. fxruby 1.4.2 (mswin32)
>                 19. fxruby 1.4.1 (mswin32)
>                 20. fxruby 1.4.1 (ruby)
>                 21. fxruby 1.4.0 (ruby) 
>                 22. fxruby 1.2.6 (mswin32)
>                 23. fxruby 1.2.6 (ruby)
>                 24. fxruby 1.2.5 (ruby)
>                 25. fxruby 1.2.5 (mswin32)
>                 26. fxruby 1.2.4 (mswin32)
>                 27. fxruby 1.2.4 (ruby)
>                 28. fxruby 1.2.3 (ruby)
>                 29. fxruby 1.2.3 (mswin32)
>                 30. fxruby 1.2.2 (ruby)
>                 31. fxruby 1.2.2 (mswin32)
>                 32. fxruby 1.2.1 (ruby)
>                 33. fxruby 1.2.1 (mswin32)
>                 34. Cancel installation
>                 > 2
>                 ERROR:  While executing gem ... (OpenURI::HTTPError) 
>                     404 Not Found
>                 
>                 _______________________________________________
>                 Rubygems-developers mailing list
>                 Rubygems-developers at rubyforge.org
>                 http://rubyforge.org/mailman/listinfo/rubygems-developers
>         
>         
>         
>         
>         -- 
>         anatol (http://feeds.feedburner.com/apomozov-eng)
>         _______________________________________________
>         Rubygems-developers mailing list
>         Rubygems-developers at rubyforge.org
>         http://rubyforge.org/mailman/listinfo/rubygems-developers
>         
> 



More information about the Rubygems-developers mailing list