[Rubygems-developers] RubyGems DeveloperGuide ???

Yvon Thoraval yvon_thoraval at mac.com
Tue Sep 19 13:00:55 EDT 2006


Hey all,

i'm looking for DeveloperGuide, i didn't find one even after
googleing...

because i get :

 > gem build system_profile.gemspec
ERROR:  While executing gem ... (Errno::ENOENT)
     No such file or directory -

then, i re-run gem build with trace'n debug options :

 > gem build system_profile.gemspec --backtrace --debug

and i get :

Exception `OptionParser::InvalidOption' at
/opt/local/lib/ruby/1.8/optparse.rb:1445 - invalid option: gen-rdoc
Exception `OptionParser::InvalidOption' at
/opt/local/lib/ruby/1.8/optparse.rb:1280 - invalid option: --gen-rdoc
Exception `OptionParser::InvalidOption' at
/opt/local/lib/ruby/1.8/optparse.rb:1445 - invalid option: run-tests
Exception `OptionParser::InvalidOption' at
/opt/local/lib/ruby/1.8/optparse.rb:1280 - invalid option: --run-tests
Exception `Errno::ENOENT' at
/opt/local/lib/ruby/site_ruby/1.8/rubygems/builder.rb:55 - No such file
or directory -
ERROR:  While executing gem ... (Errno::ENOENT)
     No such file or directory -
/opt/local/lib/ruby/site_ruby/1.8/rubygems/builder.rb:55:in `size'
/opt/local/lib/ruby/site_ruby/1.8/rubygems/builder.rb:55:in `build'
/opt/local/lib/ruby/site_ruby/1.8/rubygems/builder.rb:52:in `build'
/opt/local/lib/ruby/site_ruby/1.8/rubygems/package.rb:709:in
`open_from_io'
/opt/local/lib/ruby/site_ruby/1.8/rubygems/package.rb:219:in `new'
/opt/local/lib/ruby/site_ruby/1.8/rubygems/package.rb:702:in
`open_from_io'
/opt/local/lib/ruby/site_ruby/1.8/rubygems/package.rb:254:in `add_file'
/opt/local/lib/ruby/site_ruby/1.8/rubygems/package.rb:697:in
`open_from_io'
/opt/local/lib/ruby/site_ruby/1.8/rubygems/package.rb:685:in `open'
/opt/local/lib/ruby/site_ruby/1.8/rubygems/package.rb:789:in `open'
/opt/local/lib/ruby/site_ruby/1.8/rubygems/builder.rb:50:in `build'
/opt/local/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:619:in
`execute'
/opt/local/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:618:in
`execute'
/opt/local/lib/ruby/site_ruby/1.8/rubygems/command.rb:69:in `invoke'
/opt/local/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:117:in
`process_args'
/opt/local/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:88:in `run'
/opt/local/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:29:in `run'
/opt/local/bin/gem:23

here is my spec file :

--- system_profile.gemspec  
------------------------------------------------------------------------ 
-----
#!/usr/bin/env ruby
#
#    system_profile.gemspec
#

require 'rubygems'

spec = Gem::Specification.new do |s|
   s.name = 'SystemProfile'
   s.version = "0.0.0"
#  s.platform = Gem::Platform::RUBY::OSX
#  s.platform = Gem::Platform::OSX
   s.summary = "SystemProfile provides reading of System Profiler  
over Mac OS X 10.+."
   s.requirements << 'MacOS X 10.+'
   s.files = File.read('FILES').split( $/)
   s.test_files = Dir.glob('test/test_*.rb')
   s.extensions << 'ext/extconf.rb'
   s.has_rdoc = true
   s.author = "Yvon Thoraval"
   s.email = "yvon_thoraval at mac.com"
   s.rubyforge_project = "SystemProfile"
   s.homepage = "http://rubyforge.org/projects/system_profile/"
   s.description = <<-EOF
     SystemProfile provides reading of System Profiler over Mac OS X  
10.+.
     It outputs a Hash where you could make search of an item.
     See sample/sample.rb for more info.
   EOF
   s.required_ruby_version = '>= 1.8.4'
end

if $0==__FILE__
   Gem.manage_gems
   Gem::Builder.new(spec).build
end
------------------------------------------------------------------------ 
------------------------------------------

at this time this is a "pure Ruby" project, i'm under way having that  
tranlated into C ext 4 R...


hoping someone find the prob,

Yvon


More information about the Rubygems-developers mailing list