[Rubygems-developers] rubygems broken after ruby upgrade

Yvon Thoraval yvon_thoraval at mac.com
Fri Oct 27 02:27:34 EDT 2006


Hel all,

recently i've upgraded Ruby up to 1.8.5 using MacPort and my rubygems 
install is broken.

the guys from darwinports seems irresponsible then i have to find a 
workaround by myself.


then, what could i do sauing uninctalling rubygems and re-installing 
afterwards ?

is that a goo idea and safe one ?


look even the simplest command is broken :

~%> gem list  -l
/opt/local/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:52:in 
`initialize': uninitialized constant Gem::CommandManager::HelpCommand 
(NameError)
        from 
/opt/local/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:46:in `new'
        from 
/opt/local/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:46:in `instance'
        from 
/opt/local/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:25:in `run'
        from /opt/local/bin/gem:23


best,

Yvon


More information about the Rubygems-developers mailing list