[Rubygems-developers] Fwd: How do I tell gem to always get the MSWin32 version, if one is available?

Jim Weirich jim at weirichhouse.org
Sun Oct 15 15:29:02 EDT 2006


Chad Fowler wrote:
> It's stupid right now.  We're talking about doing a a revamp of the
> way the platform thing works (what we have now was never meant to be
> the final version), but maybe it woud be worth adding an option for
> now that just sets a preferred platform?  That way, if you specify the
> platform string correctly and exactly as its set for the gem on the
> server, it doesn't ask.  If you don't specify it or it doesn't match
> any exactly, it prompts.
> 
> What does everyone think?

The gem identification thing is the next big item ticket on my plate.  I 
want to get the JRuby .jar thing settled first, then I'm off to look at 
the platform issue.

I would suggest not adding stopgap measures for now.  I don't think it 
will take that much to do the right thing.

I'll have to dig up my notes on this and post on this soon.

-- Jim Weirich


More information about the Rubygems-developers mailing list