[Rubygems-developers] JRuby Gems

Ola Bini ola.bini at ki.se
Tue Oct 3 07:13:29 EDT 2006

Michael Studman wrote:
> require and thus determine which gem should be activated so I bet if you 
> changed it (in custom_require.rb) to:
>    SUFFIX_PATTERN = "{,.rb,.rbw,.so,.bundle,.dll,.sl,.jar}"
> It might just work. Can you test this out?
> Michael.

OK, so it seems that to get jar-files to be requireable through 
RubyGems, the constant SUFFIX_PATTERN in custom_require.rb and 
loadpath_manager.rb would need to be updated, like this:

SUFFIX_PATTERN = "{,.rb,.rbw,.so,.bundle,.dll,.sl,.jar}"

Is this possible?

  Ola Bini (http://ola-bini.blogspot.com)
  JvYAML, RbYAML, JRuby and Jatha contributor
  System Developer, Karolinska Institutet (http://www.ki.se)
  OLogix Consulting (http://www.ologix.com)

  "Yields falsehood when quined" yields falsehood when quined.

More information about the Rubygems-developers mailing list