[Rubygems-developers] Local install on Solaris fails

Florian Scharinger florian at epcc.ed.ac.uk
Wed Nov 15 10:50:41 EST 2006


Hi,

I'm trying to install rubygems in my user directory on a Solaris 9
machine, but fail in the last step.

I followed this description: http://docs.rubygems.org/read/chapter/3#page83
and also read and tried the recent post:
http://rubyforge.org/pipermail/rubygems-developers/2006-November/002201.html


The installation fails in the last step "ruby setup.rb install", with
the following output:

<loads of install messages>
As of RubyGems 0.8.0, library stubs are no longer needed.
Searching $LOAD_PATH for stubs to optionally delete (may take a while)...
...done.
No library stubs found.

/usr/local/lib/ruby/1.8/sparc-solaris2.9/digest/md5.so: ld.so.1: ruby:
fatal: libcrypto.so.0.9.8: open failed: No such file or directory -
/usr/local/lib/ruby/1.8/sparc-solaris2.9/digest/md5.so (LoadError)
         from ./lib/rubygems/custom_require.rb:27:in `require'
         from ./lib/rubygems/package.rb:10
         from ./lib/rubygems/custom_require.rb:27:in `require'
         from ./lib/rubygems/builder.rb:7
         from ./lib/rubygems/custom_require.rb:27:in `require'
         from ./lib/rubygems.rb:93:in `manage_gems'
         from /home/scharinf/tmp/rubygems-0.9.0/./post-install.rb:70:in
`install_sources'
         from /home/scharinf/tmp/rubygems-0.9.0/./post-install.rb:81:in
`try_run_hook'
         from setup.rb:577:in `run_hook'
         from setup.rb:1315:in `exec_task_traverse'
         from setup.rb:1168:in `exec_install'
         from setup.rb:887:in `exec_install'
         from setup.rb:710:in `invoke'
         from setup.rb:674:in `invoke'
         from setup.rb:1352

What can I do that the "libcrypto.so.0.9.8" is found, or work around it?

My main problem is that I'm just a user, and cannot modify the system
really...

Thx in advance for any help,
Florian.




More information about the Rubygems-developers mailing list