[Rubygems-developers] gems 0.9.0 on ruby 1.8.2 +ubuntu 6.10 : now way to install to $HOME

Jim Weirich jim.weirich at gmail.com
Sun Nov 5 00:07:43 EST 2006


On 11/4/06, Alexander Mikhailian <mikhailian at altern.org> wrote:
>
> > Try this:
> >
> > export GEM_HOME=/home/lowry/lib/ruby/gems/1.8
> > ruby setup.rb all --prefix=/home/lowry
>
> It worked like a charm!
>
> But I could not go further.
>
> Actually, when I run "gem" from the command line, I get
>
> /home/lowry/bin/gem:9:in `require': no such file to load -- rubygems
> (LoadError)
>         from /home/lowry/bin/gem:9
>
> It probably looks for the file at "lib/site_ruby/1.8/rubygems.rb", but
> can't find it.


Rubygems was installed in /home/lowry, right?  Is that where the Ruby
interpreter was installed?  If not, you have to let it know where to find
its libraries.  You can do that by setting an environment variable
(something like RUBY_PATH or RUBY_LIB or RUBY_DIR, perhaps without the
underscore ... check the documentation).

-- 
-- 
-- Jim Weirich    jim at weirichhouse.org     http://onestepback.org
-----------------------------------------------------------------
"Beware of bugs in the above code; I have only proved it correct,
not tried it." -- Donald Knuth (in a memo to Peter van Emde Boas)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/rubygems-developers/attachments/20061105/a9f3f8cf/attachment.html 


More information about the Rubygems-developers mailing list