[Rubygems-developers] CVS Head Gem has problems installing latest rails

Anatol Pomozov anatol.pomozov at gmail.com
Fri Mar 31 18:32:08 EST 2006


Hi, folk.

I have the same problem (Unhandled special: Special:) for a lot of
gem-packages, not only for rails. Also on 1.8.2 and 1.8.4 on Windows
platform.

Very annoying error.

On 4/1/06, Jim Weirich <jim at weirichhouse.org> wrote:
>
> I get the following while installing a the latest version of rails.
>
> $ sudo gem install rails -y
> Successfully installed rails-1.1.0
> Successfully installed activerecord-1.14.0
> Successfully installed actionpack-1.12.0
> Successfully installed actionmailer-1.2.0
> Successfully installed actionwebservice-1.1.0
> Installing ri documentation for activerecord-1.14.0...
> Installing RDoc documentation for activerecord-1.14.0...
> Installing ri documentation for actionpack-1.12.0...
> ERROR:  While executing gem ... (RuntimeError)
>      Unhandled special: Special: type=17, text="SimpleXML"
>
> This happened on both windows and linux.  The windows box is running
> version ruby 1.8.2, the linux box is 1.8.4.  Both boxes are running the
> CVS head for gems, which runs the RI documentation generator.  Since I'm
> not hearing complaints from other users, I suspect that it is an RI doc
> issue.
>
> I ran "gem rdoc" on each of the packages individually and had no problem
> (on the windows box ... haven't tried it on linux yet).
>
> Anyone who know the RI doc process better than I do wish to comment?
>
>
--
anatol (http://pomozov.info)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/rubygems-developers/attachments/20060401/d9a48250/attachment.htm 


More information about the Rubygems-developers mailing list