[Rubygems-developers] CVS Head Gem has problems installing latest rails

Jim Weirich jim at weirichhouse.org
Fri Mar 31 17:16:00 EST 2006


I get the following while installing a the latest version of rails.

$ sudo gem install rails -y
Successfully installed rails-1.1.0
Successfully installed activerecord-1.14.0
Successfully installed actionpack-1.12.0
Successfully installed actionmailer-1.2.0
Successfully installed actionwebservice-1.1.0
Installing ri documentation for activerecord-1.14.0...
Installing RDoc documentation for activerecord-1.14.0...
Installing ri documentation for actionpack-1.12.0...
ERROR:  While executing gem ... (RuntimeError)
     Unhandled special: Special: type=17, text="SimpleXML"

This happened on both windows and linux.  The windows box is running 
version ruby 1.8.2, the linux box is 1.8.4.  Both boxes are running the 
CVS head for gems, which runs the RI documentation generator.  Since I'm 
not hearing complaints from other users, I suspect that it is an RI doc 
issue.

I ran "gem rdoc" on each of the packages individually and had no problem 
(on the windows box ... haven't tried it on linux yet).

Anyone who know the RI doc process better than I do wish to comment?

-- 
-- Jim Weirich    jim at weirichhouse.org     http://onestepback.org
-----------------------------------------------------------------
"Beware of bugs in the above code; I have only proved it correct,
not tried it." -- Donald Knuth (in a memo to Peter van Emde Boas)


More information about the Rubygems-developers mailing list