[Rubygems-developers] gems 0.9.0 fails to install rails

Chris Tirpak ctirpak at gmail.com
Fri Jun 30 02:15:14 EDT 2006

Howdy -

Please accept my apologies if this is off topic -- it seems to be the
correct place, I'll happily relocate the question if its the incorrect

I have a SUSE 10.1 machine that I've installed ruby and rails on -
both from sources rather than the SUSE packages.  When I try to add
rails I get the following:

zippity:/usr/src/rubygems-0.9.0 # ruby -v
ruby 1.8.4 (2005-12-24) [i686-linux]
zippity:/usr/src/rubygems-0.9.0 # gem -v
zippity:/usr/src/rubygems-0.9.0 # gem install rails --include-dependencies
ERROR:  While executing gem ... (OpenURI::HTTPError)
    300 Multiple Choices
zippity:/usr/src/rubygems-0.9.0 #

I tried this and then re-running the above sequence and the results
were the same:

zippity:/usr/src/rubygems-0.9.0 # gem update --system
Updating RubyGems...
Attempting remote update of rubygems-update
Successfully installed rubygems-update-0.9.0
Updating version of RubyGems to 0.9.0
Installing RubyGems 0.9.0
---> bin
<--- bin
---> lib
<snip>..... lots of normal looking messages
<--- lib/rbconfig
<--- lib
As of RubyGems 0.8.0, library stubs are no longer needed.
Searching $LOAD_PATH for stubs to optionally delete (may take a while)...
No library stubs found.

  Successfully built RubyGem
  Name: sources
  Version: 0.0.1
  File: sources-0.0.1.gem
RubyGems system software updated

Any suggestions?


More information about the Rubygems-developers mailing list