[Rubygems-developers] SUPPORT: Unable to update to 0.9.0 rubygems from 0.8.11 on Windows XP Pro

Chad Fowler chad at chadfowler.com
Wed Jun 28 13:05:19 EDT 2006


On Jun 28, 2006, at 11:00 AM, Wes Gamble wrote:

> All,
>
> I couldn't find a support list for rubygems so my apologies in  
> advance for posting to the developers list.
>
> I have gems 0.8.11 and I attempted gem update --system and got the   
> output below.
>
> What do I need to do to make the update work?
>
> Do I need to issue the command in the ruby home directory?
>
> Should I just install rubygems 0.9 from scratch? Does that have any  
> implications?
>
> In fact, if I just do a "gem update" command, I get the same error  
> (I believe that's because it's trying to install
> the rubygem-update gem).
>
> Thanks,
> Wes
>
> ====================================================================
> C:\eclipse\workspace>gem -v
> 0.8.11
>
> C:\eclipse\workspace>gem update --system
> Upgrading RubyGems...
> Updating Gem source index for: http://gems.rubyforge.org
> ERROR:  While executing gem ... (ArgumentError)
>     syntax error on line 142941, col 1175: `: RubyGems is a package
> management f
> ramework for Ruby.  This Gem is a update for the base RubyGems  
> software.
> You mu
> st have a base installation of RubyGems before this update can be
> applied.
>     autorequire:
>     default_executable:
>     bindir: bin
>     has_rdoc:
>     required_ruby_version: !ruby/object:Gem::Version::Requirement
>       requirements:
>       - - ">"
>         - !ruby/object:Gem::Version
>           version: 0.0.0
>     platform:
>     signing_key:
>     cert_

Hi.  This was a problem on the server.  Rich and Tom just fixed it.   
We need to fix RubyGems to be more resilient to this sort of thing.

Chad




More information about the Rubygems-developers mailing list