[Rubygems-developers] gems.rubyforge.org/yaml corrupt?

Jason Dusek jsn.s.rubix.cube at gmail.com
Tue Jun 27 19:58:17 EDT 2006


hi,

when i try to install something with gem, like this:

     gem install postgresql

i get a 'syntax error' and a bunch of yaml:

  Attempting local installation of 'postgresql'
  Local gem file not found: postgresql*.gem
  Attempting remote installation of 'postgresql'
  Updating Gem source index for: http://gems.rubyforge.org
  ERROR:  While executing gem ... (ArgumentError)
      syntax error on line 142311, col 1177: `     - - ">"
          - !ruby/object:Gem::Version
            version: 0.0.0
        version:
      platform: ruby
    </...etc...>


    activesalesforce-0.0.2: !ruby/object:Gem::Specification
    </...etc...>

it turns out this happens whenever i try to install anything at all.
my install of gem seems to be okay - i can run 'gem list' and the like
without any trouble.

the error line admonishes us "syntax error on line 142311, col 1177".
i downloaded the yaml file from gems.rubyforge.org and tried to figure
out what was wrong with it. if you go to line 142311, there's nothing
special about it, except that it's not long enough to have a column
1177:

    rubyforge_project: trestle

however, the line below it is very long and has an non-numeric control
sequence, \xFC, at column 1170. could this be the cause of the
problem? i don't know - i'm not sure how to get gems to read a local
copy of the yaml repository listing.

if this isn't the right mailing list for this topic, please let me
know. i'm new to ruby and would very much like to get off on the right
foot.
-- 
_jsn


More information about the Rubygems-developers mailing list