[Rubygems-developers] error when irb not installed

Jim Freeze rubygems at freeze.org
Wed Dec 27 08:08:36 EST 2006


On Dec 27, 2006, at 1:38 AM, Eric Hodel wrote:

> On Dec 26, 2006, at 21:20, Jim Freeze wrote:
>
>> Should I be getting an error when installing a gem on
>> a machine that irb is not installed on?
>
> Yes.  Rubygems requires all of ruby to be installed.

Maybe it should more gracefully fail. I was using CentOS at the
time, and had installed ruby with 'yum install ruby'. It is an  
additional
install 'yum install irb' to get irb. :(


Jim Freeze



-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/rubygems-developers/attachments/20061227/ba83a9be/attachment.html 


More information about the Rubygems-developers mailing list