[Rubygems-developers] error when irb not installed

Eric Hodel drbrain at segment7.net
Wed Dec 27 02:38:44 EST 2006


On Dec 26, 2006, at 21:20, Jim Freeze wrote:

> Should I be getting an error when installing a gem on
> a machine that irb is not installed on?

Yes.  Rubygems requires all of ruby to be installed.

> It appears that the install completes, but during the doc install,
> gem crashes when irb is not installed.
>
> /usr/lib/site_ruby/1.8/rubygems/custom_require.rb:35:in `require':  
> No such file to load -- irb/slex (LoadError)
>         from /usr/lib/site_ruby/1.8/rubygems/doc_manager.rb:71:in  
> `load_rdoc'

RDoc depends on irb.

$ cat -n lib/rubygems/doc_manager.rb | grep 71
     71          require 'rdoc/rdoc'

-- 
Eric Hodel - drbrain at segment7.net - http://blog.segment7.net

I LIT YOUR GEM ON FIRE!



More information about the Rubygems-developers mailing list