[Rubygems-developers] [rubygems] Build still broken (#1149)

Cerberus anatol.pomozov at gmail.com
Wed Dec 20 05:01:55 EST 2006


------------------------------------------------------------------------
r1149 | drbrain | 2006-12-20 12:57:32 +0300 | 3 lines
Changed paths:
   M /trunk/test/test_gem_ext_configure_builder.rb
   M /trunk/test/test_gem_ext_ext_conf_builder.rb

Remove test_class_build_extconf_bad, cross-compiler behavior is not constant.
PLATFORM not VERSION, you idiot.

------------------------------------------------------------------------

(in C:/Documents and Settings/anatol/.cerberus/work/rubygems/sources)
Loaded suite c:/PROGRA~1/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake/rake_test_loader
Started
..............................................................................................F.......................................................................................F..............................................................................................
Finished in 56.359 seconds.

  1) Failure:
test_class_build_fail(TestGemExtRakeBuilder) [./test/test_gem_ext_rake_builder.rb:46]:
<Gem::InstallError> exception expected but none was thrown.

  2) Failure:
test_source_index_hash(TestRemoteInstaller) [./test/test_remote_installer.rb:87]:
<1> expected but was
<6>.

277 tests, 982 assertions, 2 failures, 0 errors
rake aborted!
Command failed with status (1): [c:/PROGRA~1/ruby/bin/ruby -w -Ilib "c:/PRO...]

(See full trace by running task with --trace)

--
Cerberus 0.3.2, http://cerberus.rubyforge.org/


More information about the Rubygems-developers mailing list