[Rubygems-developers] RubyGems 0.9.0 introduces bug for installing source Gems

Tilman Sauerbeck tilman at code-monkey.de
Fri Aug 11 12:53:23 EDT 2006


Jim Weirich [2006-08-10 14:27]:
> Tilman Sauerbeck wrote:
> > Does nobody think this issue is important enough to actually do
> > something about it (like, applying a patch and rolling 0.9.1)!?
> 
> [...]
>
> (2) I've included Tilman's patch to the ext lib building.  Tilman, would 
> you please check to make sure it is ok.  Thanks.

I tested the ExtConf builder with the imlib2-ruby gem, and it's okay.
My Rake-based gem builds fine, too.

I didn't exercise the new Configure builder, but as it's mostly based on
the ExtConf one (or the other way round, too lazy to check right now) I
assume it will work, too.

For the next rubygems release after this one, I'd like to be able to
remove object files from the gem directory. Also, some gems might have
two copies of the shared object around right now (one in the build
directory, one in the destination directory).
But that doesn't need to be fixed in this release IMO.

Regards,
Tilman

-- 
A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing on usenet and in e-mail?
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://rubyforge.org/pipermail/rubygems-developers/attachments/20060811/116c22df/attachment.bin 


More information about the Rubygems-developers mailing list