[Rubygems-developers] Problem building gem without loading gem reuqire system.

TRANS transfire at gmail.com
Fri Apr 21 21:54:25 EDT 2006


Hi,

I've created a script for automating the building a gem, among other
things, but I have to use

  require 'rubygems'

in the script to make it work. Unfortuately that causes Gems to take
control of the require mechanism  and thus the script can't be run in
such a way as to bypass the Gems system --i.e. a manual install
overriding a gems install.

How can this be fixed?

Thanks,
T.



More information about the Rubygems-developers mailing list