[Rubygems-developers] The replacement for 'require_gem'

Gregory Brown gregory.t.brown at gmail.com
Thu Apr 6 15:53:34 EDT 2006


On 4/5/06, Jim Weirich <jim at weirichhouse.org> wrote:
> We've been talking about a replacement for 'require_gem' that does not
> do the auto-requiring.  Several names have been suggested (e.g.
> activate_gem).
>
> Here's what I'm leaning towards:
>
>    require "rubygems"
>    gem 'rails', '= 1.0.0'
>    gem 'rake', '= 0.7.0.1'
>    gem 'activesupport', '= 1.2.5'
>    gem 'activerecord', '= 1.13.2'
>    gem 'actionpack', '= 1.11.2'
>    gem 'actionmailer', '= 1.1.5'
>    gem 'actionwebservice', '= 1.0.0'
>
> I like it because I don't have to explain what 'activate' means :)
>
> Comments?

use_gem ?

use_gem 'rake'

Otherwise, just gem sounds okay.



More information about the Rubygems-developers mailing list