[Rubygems-developers] The replacement for 'require_gem'

Jim Weirich jim at weirichhouse.org
Wed Apr 5 12:53:52 EDT 2006


We've been talking about a replacement for 'require_gem' that does not 
do the auto-requiring.  Several names have been suggested (e.g. 
activate_gem).

Here's what I'm leaning towards:

   require "rubygems"
   gem 'rails', '= 1.0.0'
   gem 'rake', '= 0.7.0.1'
   gem 'activesupport', '= 1.2.5'
   gem 'activerecord', '= 1.13.2'
   gem 'actionpack', '= 1.11.2'
   gem 'actionmailer', '= 1.1.5'
   gem 'actionwebservice', '= 1.0.0'

I like it because I don't have to explain what 'activate' means :)

Comments?

-- 
-- Jim Weirich       jweirich at one.net      http://onestepback.org
-----------------------------------------------------------------
"Beware of bugs in the above code; I have only proved it correct,
not tried it." -- Donald Knuth (in a memo to Peter van Emde Boas)


More information about the Rubygems-developers mailing list