[Rubygems-developers] ri support w/ gem rdoc install

chad@chadfowler.com chad at chadfowler.com
Fri Sep 30 13:36:45 EDT 2005


> On 9/30/05, John-Mason P. Shackelford <jpshack at gmail.com> wrote:
>> I'd love to see gems offer an rdoc install that would support ri as
>> well as rdoc since it would be very handy for ruby IDEs which use the
>> ri data. It occurs to me that this may require a patch to both gems
>> and ri. Have the ruby gems developers reached any conclusions about
>> how they would like to see this implemented?
>
> This is mostly something where ri will probably need to be
> reengineered. Right now it's useful for single system-wide installs
> only. It doesn't update well.
>

Actually Dave, Mauricio, and I exchanged a few emails some time back about
how to handle this.  It is true that the merge problem would exist (you
couldn't uninstall ri documentation), but we did talk about putting in a
new rdoc ri directory for holding the ri data for packaging systems.  The
patch would be trivial on both sides, actually.  It probably makes sense
to do this with the inclusion of RubyGems with ruby 1.8.4.

Chad



More information about the Rubygems-developers mailing list