[Rubygems-developers] rubygems LoadError driving me insane

Ryan Raaum ryan.raaum at gmail.com
Wed Sep 7 12:48:35 EDT 2005


Hi Chad,

> Hi Ryan!  Can you perhaps print out the contents of $: from within
> the forked script?

Ok. (long long paths...).  The /Users/ryan/... path is the one I am
trying to use.  The /Applications/Locomotive.app/... path is where I
initially configured the ruby/gems tree - however, that file tree no
longer exists, but seems to be hardcoded into ruby somewhere that I
haven't been able to find...

If I clean out my environment on the command line and set my PATH and
RUBYLIB there - things work...

/Users/ryan/Development/locomotive-trunk/build/Locomotive.app/rails-0.13.1/lib/ruby/site-ruby/1.8
/Users/ryan/Development/locomotive-trunk/build/Locomotive.app/rails-0.13.1/lib/ruby/site-ruby/1.8/powerpc-darwin7.9.0
/Users/ryan/Development/locomotive-trunk/build/Locomotive.app/rails-0.13.1/lib/ruby/site-ruby
/Users/ryan/Development/locomotive-trunk/build/Locomotive.app/rails-0.13.1/lib/ruby/1.8
/Users/ryan/Development/locomotive-trunk/build/Locomotive.app/rails-0.13.1/lib/ruby/1.8/powerpc-darwin7.9.0
/Applications/Locomotive.app/rails-0.13.1/lib/ruby/site_ruby/1.8
/Applications/Locomotive.app/rails-0.13.1/lib/ruby/site_ruby/1.8/powerpc-darwin7.9.0
/Applications/Locomotive.app/rails-0.13.1/lib/ruby/site_ruby
/Applications/Locomotive.app/rails-0.13.1/lib/ruby/1.8
/Applications/Locomotive.app/rails-0.13.1/lib/ruby/1.8/powerpc-darwin7.9.0
.

Any ideas you have would be great!

Thanks!

--ryan



More information about the Rubygems-developers mailing list