[Rubygems-developers] Problems with RemoteInstaller

Mauricio Fernández mfp at acm.org
Sun Nov 13 10:05:47 EST 2005


On Sun, Nov 13, 2005 at 09:07:44AM -0500, Chad Fowler wrote:
> On Nov 12, 2005, at 7:11 PM, Mauricio Fernández wrote:
> > It was a workaround for a bug in an older open-uri (as opposed to a  way
> > to use open-uri in outdated Ruby setups).
[...]
> Yes, true.  We should do some testing with various open-uri versions  
> and perhaps change the minimum ruby version requirement for rubygems.

IIRC the open-uri shipped with Ruby 1.8.1 exhibited the bug that bit us
and which was finally fixed on Jan 31st 2004. Hence 
  RUBY_VERSION_CODE > 181 || RUBY_RELEASE_CODE > 20040131
should be OK, unless new dependencies were added later.

-- 
Mauricio Fernandez


More information about the Rubygems-developers mailing list