[Rubygems-developers] gem uninstall bug

Chad Fowler chad at chadfowler.com
Thu Nov 3 10:53:10 EST 2005


On 02-Nov-05, at 5:42 PM, Eric Hodel wrote:

> $ sudo gem uninstall rails
> Attempting to uninstall gem 'rails'
>
> Select RubyGem to uninstall:
> 1. rails-0.14.2
> 2. rails_analyzer_tools-1.1.0
> 3. All versions
>> 1
> Successfully uninstalled rails version 0.14.2
> Remove executables and scripts for
> 'rails_stat, bench, crawl' in addition to the gem? [Yn]
>
> rails_stat, bench and crawl are part of rails_analyzer_tools, not
> rails itself, so gems shouldn't be asking me to uninstall them.

Yuck.  I'll check it out later today.

Thanks,
Chad



More information about the Rubygems-developers mailing list