[Rubygems-developers] require issue with 0.8.10

Assaph Mehr assaph at gmail.com
Mon Mar 28 23:56:47 EST 2005


> With RUBYOPT set and gem 0.8.10:
> 
>   $ ruby -e 'require "html/tree"; puts "OK"'
>   OK

I swear I tested this a dozen times and it failed... until now.

> > With gems 0.8.10 it doesn't (complaining
> > 'LoadError: No such file to load -- html/tools').
> 
> What is 'html/tools'?  I didn't see any file by that name (although the name
> of the gem is htmltools).  Nor could I find any reference to that file in the
> source code of htmltools.

I must have had a brainfart, reading 'tree' where 'tools' was written...
Thanks for your patience towards the mentally chalanged ;-)

Cheers,
Assaph


More information about the Rubygems-developers mailing list