[Rubygems-developers] require issue with 0.8.10

Assaph Mehr assaph at gmail.com
Mon Mar 28 20:12:35 EST 2005


Hi Guys,

The HTMLTools gem, which used to work with gems 0.8.8, now gives me
grief using gems 0.8.10 due to (I presume) a behaviour change in
#require.

I have RUBYOPT=rubygems set  on my machine (WinXP, ruby 1.8.2). I used
to be able to simply require the files I needed from the gems, e.g.:
  require 'html/tree'
which would load fine. With gems 0.8.10 it doesn't (complaining
'LoadError: No such file to load -- html/tools'). I think that's
because all files in the gem are under its lib/html directory, and all
files require other files (in the same dir) via require
'html/somefile'.
So something now prevents it from picking up those files that are in
the same dir.

Changing it to: 
  require_gem 'htmltools'   # gemspec has autorequire set
(or adding the gem/lib dir to $LOAD_PATH) fixes this for me, but I was
wondering about the behaviour change.

Cheers,
Assaph


More information about the Rubygems-developers mailing list