[Rubygems-developers] Some errors

Tobias Luetke tobias.luetke at gmail.com
Wed Mar 23 10:06:17 EST 2005


The 0.8.8.2 installed rails fine. 
However it installed activesupport a couple times to many but that
doesn't do any harm:

tobi at tobmac rubygems $ gem install rails
Attempting local installation of 'rails'
Local gem file not found: rails*.gem
Attempting remote installation of 'rails'
Updating Gem source index for: http://gems.rubyforge.org
Install required dependency activesupport? [Yn]  y
Install required dependency activerecord? [Yn]  y
Install required dependency activesupport? [Yn]  y
Install required dependency actionmailer? [Yn]  y
Install required dependency actionwebservice? [Yn]  y
Install required dependency activerecord? [Yn]  y
Install required dependency activesupport? [Yn]  y
Install required dependency activesupport? [Yn]  y
Successfully installed rails-0.11.0
Successfully installed activesupport-1.0.2
Successfully installed activerecord-1.9.0
Successfully installed activesupport-1.0.2
Successfully installed actionmailer-0.8.0
Successfully installed actionwebservice-0.6.1
Successfully installed activerecord-1.9.0
Successfully installed activesupport-1.0.2
Successfully installed activesupport-1.0.2
Installing RDoc documentation for activesupport-1.0.2...
Installing RDoc documentation for activerecord-1.9.0...
Installing RDoc documentation for activesupport-1.0.2...
Installing RDoc documentation for actionmailer-0.8.0...
Installing RDoc documentation for actionwebservice-0.6.1...
Installing RDoc documentation for activerecord-1.9.0...
Installing RDoc documentation for activesupport-1.0.2...
Installing RDoc documentation for activesupport-1.0.2...


On Wed, 23 Mar 2005 08:17:56 -0500, Jim Weirich <jim at weirichhouse.org> wrote:
> On Tuesday 22 March 2005 12:31 pm, Jim Weirich wrote:
> > Tobias Luetke said:
> > > Hello,
> > >
> > > I'm running gems 0.8.8.1 (thanks to jim and the fix about version
> > > pinning) but ran in some problems this
> > > morning upgrading rails.
> > >
> > > I attach a transcript of what happened, basically i had to run gem
> > > update multiple times to finish the process.
> > >
> > > Its only my CVS version as others seem to update just fine. Feel free
> > > to ignore this.
> >
> > Thanks ... I will check this out this evening.
> 
> The latest CVS version (0.8.8.2) has a fix for this.  It needs more testing
> before release, but if you could try it out, I would appreciate it.
> 
> Thanks.
> 
> --
> -- Jim Weirich    jim at weirichhouse.org     http://onestepback.org
> -----------------------------------------------------------------
> "Beware of bugs in the above code; I have only proved it correct,
> not tried it." -- Donald Knuth (in a memo to Peter van Emde Boas)
> 


-- 
Tobi
http://www.snowdevil.ca - Snowboards that don't suck
http://www.hieraki.org   - Open source book authoring
http://blog.leetsoft.com - Technical weblog


More information about the Rubygems-developers mailing list