[Rubygems-developers] Some errors

Tobias Luetke tobias.luetke at gmail.com
Tue Mar 22 09:57:50 EST 2005


Hello, 

I'm running gems 0.8.8.1 (thanks to jim and the fix about version
pinning) but ran in some problems this
morning upgrading rails.

I attach a transcript of what happened, basically i had to run gem
update multiple times to finish the process.

Its only my CVS version as others seem to update just fine. Feel free
to ignore this.

-- 
Tobi
http://www.snowdevil.ca - Snowboards that don't suck
http://www.hieraki.org   - Open source book authoring
http://blog.leetsoft.com - Technical weblog
-------------- next part --------------
Last login: Tue Mar 22 09:00:57 on console
Welcome to Darwin!
tobi at tobmac tobi $ gem update
Password:
Upgrading installed gems...
Updating Gem source index for: http://gems.rubyforge.org
Attempting remote upgrade of actionmailer
Attempting remote installation of 'actionmailer'
Install required dependency actionpack? [Yn]  y
Install required dependency activesupport? [Yn]  y
/usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:195:in `report_activate_error': RubyGem version error: activesupport(1.0.0 not = 1.0.2) (Gem::LoadError)
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:137:in `activate'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:38:in `require_gem_with_options'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/installer.rb:60:in `install'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/installer.rb:58:in `each'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/installer.rb:58:in `install'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/remote_installer.rb:385:in `install'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/remote_installer.rb:489:in `install_dependencies'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/remote_installer.rb:485:in `each'
         ... 9 levels...
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:92:in `process_args'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:65:in `run'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:9:in `run'
        from /usr/local/bin/gem:17
tobi at tobmac tobi $ gem update
Upgrading installed gems...
Attempting remote upgrade of actionmailer
Attempting remote installation of 'actionmailer'
Install required dependency actionpack? [Yn]  y
/usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:195:in `report_activate_error': RubyGem version error: actionpack(1.4.0 not = 1.6.0) (Gem::LoadError)
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:137:in `activate'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:38:in `require_gem_with_options'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/installer.rb:60:in `install'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/installer.rb:58:in `each'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/installer.rb:58:in `install'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/remote_installer.rb:385:in `install'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:179:in `execute'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:137:in `each'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:137:in `execute'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:694:in `execute'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:690:in `each'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:690:in `execute'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/command.rb:49:in `invoke'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:92:in `process_args'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:65:in `run'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:9:in `run'
        from /usr/local/bin/gem:17
tobi at tobmac tobi $ gem update
Upgrading installed gems...
Attempting remote upgrade of actionmailer
Attempting remote installation of 'actionmailer'
Successfully installed actionmailer-0.8.0
Installing RDoc documentation for actionmailer-0.8.0...
Attempting remote upgrade of actionwebservice
Attempting remote installation of 'actionwebservice'
Install required dependency activerecord? [Yn]  y
/usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:195:in `report_activate_error': RubyGem version error: activerecord(1.6.0 not = 1.9.0) (Gem::LoadError)
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:137:in `activate'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:38:in `require_gem_with_options'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/installer.rb:60:in `install'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/installer.rb:58:in `each'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/installer.rb:58:in `install'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/remote_installer.rb:385:in `install'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:179:in `execute'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:137:in `each'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:137:in `execute'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:694:in `execute'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:690:in `each'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:690:in `execute'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/command.rb:49:in `invoke'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:92:in `process_args'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:65:in `run'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:9:in `run'
        from /usr/local/bin/gem:17
tobi at tobmac tobi $ gem update
Upgrading installed gems...
Attempting remote upgrade of actionwebservice
Attempting remote installation of 'actionwebservice'
Successfully installed actionwebservice-0.6.1
Installing RDoc documentation for actionwebservice-0.6.1...
Attempting remote upgrade of rails
Attempting remote installation of 'rails'
Install required dependency actionwebservice? [Yn]  y
/usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:195:in `report_activate_error': RubyGem version error: actionwebservice(0.6.0 not = 0.6.1) (Gem::LoadError)
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:137:in `activate'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:38:in `require_gem_with_options'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/installer.rb:60:in `install'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/installer.rb:58:in `each'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/installer.rb:58:in `install'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/remote_installer.rb:385:in `install'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:179:in `execute'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:137:in `each'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:137:in `execute'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:694:in `execute'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:690:in `each'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:690:in `execute'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/command.rb:49:in `invoke'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:92:in `process_args'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:65:in `run'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:9:in `run'
        from /usr/local/bin/gem:17
tobi at tobmac tobi $ gem update
Upgrading installed gems...
Attempting remote upgrade of rails
Attempting remote installation of 'rails'
Successfully installed rails-0.11.0
Gems: [rails] updated
tobi at tobmac tobi $ gem dependency rails
Gem rails-0.9.5
  Requires
    rake (>= 0.4.15)
    activerecord (>= 1.6.0)
    actionpack (>= 1.4.0)
    actionmailer (>= 0.6.1)

Gem rails-0.10.1
  Requires
    rake (>= 0.4.15)
    activesupport (= 1.0.1)
    activerecord (= 1.8.0)
    actionpack (= 1.5.1)
    actionmailer (= 0.7.1)
    actionwebservice (= 0.6.0)

Gem rails-0.11.0
  Requires
    rake (>= 0.4.15)
    activesupport (= 1.0.2)
    activerecord (= 1.9.0)
    actionpack (= 1.6.0)
    actionmailer (= 0.8.0)
    actionwebservice (= 0.6.1)



More information about the Rubygems-developers mailing list