[Rubygems-developers] Major problem with 0.8.7

Jim Weirich jim at weirichhouse.org
Mon Mar 14 10:02:08 EST 2005

chad at chadfowler.com said:
> Jim,
>   The source index on the server wasn't updating for remote installs of
> the new version.  Rich and I looked at it, and it was actually skipping
> the 0.8.7 gem.  So, I downloaded the gem and tried to install it
> locally.  I got this:
> ERROR:  Error installing gem rubygems-update-0.8.7.gem[.gem]:
> uninitialized constant Gem::Requirement
> I noticed last night that you moved Requirement up out of Version.  I
> guess this is the problem, but I'm not sure exactly why (I'm a bit
> delirious with fever now, so I'm probably not going to figure it out
> either :)

Rats.  It's a bootstrap problem.

The Requirement object is in the Gem spec file and the existing software
needs to load the gemspec.

Sorry, I should have tried updating the gem with an older version of the
gem software.

I won't have a chance to fix this until this evening.

-- Jim Weirich     jim at weirichhouse.org    http://onestepback.org
"Beware of bugs in the above code; I have only proved it correct,
not tried it." -- Donald Knuth (in a memo to Peter van Emde Boas)

More information about the Rubygems-developers mailing list