[Rubygems-developers] Ruby Gem Install Problem on OSX

Jim Weirich jim at weirichhouse.org
Mon Mar 7 19:06:41 EST 2005

On Monday 10 January 2005 08:51 am, Jason Savidge wrote:
> Hi,
> I am trying to install Ruby and Rails so I can begin testing it for web
> development on OSX. I seem to have gotten Ruby installed and Rubygems but I
> get the following error when trying to get to next step of installing
> rails. I installed 1.8 as specified for OSX which leaves 1.6 still on the
> OSX system. It seems to be looking towards the 1.6 default install of ruby
> for some reason.

You're right, it does look like it it using the 1.6 version of Ruby.  I am 
guessing this is because (1) the 1.6 version preceeds the 1.8 version in the 
PATH environment variable, or (2) the gem command got installed so that it 
directly references the 1.6 version.  

I do see that the gems library is in the 1.6 directory tree, so you might have 
to reinstall RubyGems in the 1.8 tree. 

-- Jim Weirich    jim at weirichhouse.org     http://onestepback.org
"Beware of bugs in the above code; I have only proved it correct, 
not tried it." -- Donald Knuth (in a memo to Peter van Emde Boas)

More information about the Rubygems-developers mailing list