[Rubygems-developers] require failing on winxp

Bill Guindon agorilla at gmail.com
Tue Jun 28 14:24:28 EDT 2005


Since I finally got a server setup to try some Rails apps, I figured
I'd get my local setup up to date, but I'm having some problems with
it.

WinXP 
Ruby 1.8.2
Gems  0.8.10
Rails 0.12.1
RUBYOPT = rubygems

no errors on install, and no errors when I generate the rails app, but
when I try to kick off the server, here's what I'm seeing:

C:\Work\active\web\anarchy\snippets>ruby script/server
c:/work/active/shell/ruby/lib/ruby/gems/1.8/gems/actionmailer-0.9.1/lib/action_mailer.rb:42:
uninitialized constant ActionView::Base (NameError)
        from c:/work/active/shell/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:in
`require__'
        from c:/work/active/shell/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:in
`require'
        from c:/work/active/shell/ruby/lib/ruby/gems/1.8/gems/activesupport-1.0.4/lib/active_support/dependencies.rb:197:in
`require'
        from c:/work/active/shell/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:175:in
`activate'
        from c:/work/active/shell/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:23:in
`require'
        from c:/work/active/shell/ruby/lib/ruby/gems/1.8/gems/activesupport-1.0.4/lib/active_support/dependencies.rb:197:in
`require'
        from ./script/../config/environment.rb:41
        from c:/work/active/shell/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:in
`require__'
        from c:/work/active/shell/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:in
`require'
        from script/server:42

....
So I took a bit from what I had to do on the webserver, in the hopes
that it might fix it:

C:\Work\active\web\anarchy\snippets>echo %GEM_HOME%
%GEM_HOME%

C:\Work\active\web\anarchy\snippets>set
GEM_HOME=/work/active/shell/ruby/lib/ruby/gems/

C:\Work\active\web\anarchy\snippets>ruby script/server
c:/work/active/shell/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:in
`require__': No such file to load -- active_support (LoadError)
        from c:/work/active/shell/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:in
`require'
        from ./script/../config/environment.rb:38
        from c:/work/active/shell/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:in
`require__'
        from c:/work/active/shell/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:in
`require'
        from script/server:42

Didn't fix it, but it's a slightly different set of errors.  Any suggestions?

--
Bill Guindon (aka aGorilla)



More information about the Rubygems-developers mailing list