[Rubygems-developers] --version failing

Doug Kearns dougkearns at gmail.com
Wed Jul 20 08:02:14 EDT 2005


G'day all,

I'm a bit short on time tonight so I haven't investigated properly but
could someone confirm this for me?

(21:55)-(doug at hairbear)-(pts/17)-(10010)-(~)
(0)% gem --version
0.8.11

(21:55)-(doug at hairbear)-(pts/17)-(10011)-(~)
(0)% gem check rails --test
There are no unit tests to run for rails-0.13.1

(21:56)-(doug at hairbear)-(pts/17)-(10012)-(~)
(0)% gem check rails --test --version '> 0'
ERROR:  While executing gem ... (Gem::CommandLineError)
    Too many gem names (rails, > 0); please specify only one

It looks like the same occurs for the use of --version with the
'dependency' and 'contents' commands as well.

I also noticed when upgrading that the shebang line was changed from
"#!/usr/bin/env ruby" to "#!/specific/path/to/ruby" for gem_mirror only?

Thanks,
Doug


More information about the Rubygems-developers mailing list