[Rubygems-developers] Anothor UI wrinkle.

Doug Kearns dougkearns at gmail.com
Tue Jul 12 08:45:14 EDT 2005


On Tue, Jul 12, 2005 at 12:09:11PM +0100, Hugh Sasse wrote:

<snip>
 
> Also, when doing an install of rails on a PC I get requests for
> prerequisites with the form
>     thingumybob [Yn]
> as the the prompt.  I presumed that the upper case meant default,
> but this did seem to be defined.  Would it make sense to allow 'a'
> for All prerequisites for this gem?

Yes. I'm just starting to have a look at RubyGems and this is one of the
first things I noticed.

You can, of course, specify --include-dependencies as an option to
'install' but if you forget it's nice to have 'All' and 'None' as
options.

Regards,
Doug


More information about the Rubygems-developers mailing list