[Rubygems-developers] Anothor UI wrinkle.

Hugh Sasse hgs at dmu.ac.uk
Tue Jul 12 07:09:11 EDT 2005


Doing gem update I get

Attempting remote installation of 'fxruby'
Select which gem to install for your platform (sparc-solaris2.9)
  1. fxruby 1.2.6 (mswin32)
  2. fxruby 1.2.6 (ruby)
  3. fxruby 1.2.5 (ruby)
  4. fxruby 1.2.5 (mswin32)
  5. fxruby 1.2.4 (mswin32)
  6. fxruby 1.2.4 (ruby)
  7. fxruby 1.2.3 (mswin32)
  8. fxruby 1.2.3 (ruby)
  9. fxruby 1.2.2 (mswin32)
  10. fxruby 1.2.2 (ruby)
  11. fxruby 1.2.1 (mswin32)
  12. fxruby 1.2.1 (ruby)
  13. Cancel installation
> 10

I submit that the last item should be  "Skip installation of this gem".
Cancel installation suggests that it might abandon the update altogether.


Also, when doing an install of rails on a PC I get requests for
prerequisites with the form
     thingumybob [Yn]
as the the prompt.  I presumed that the upper case meant default,
but this did seem to be defined.  Would it make sense to allow 'a'
for All prerequisites for this gem?

         Thank you,
         Hugh


More information about the Rubygems-developers mailing list