[Rubygems-developers] Please try the release candidate for the new RubyGems version

Assaph Mehr assaph at gmail.com
Sat Jul 9 19:31:44 EDT 2005


Hi Jim,

Tried it on my WinXP box. 
First run: got an exception (on unlink), and a message that the
software updated.
Second (consecutive) run: looks like it made it.

HTH,
Assaph

*** System:
c:\>ruby -v
ruby 1.8.2 (2004-12-25) [i386-mswin32]

*** First run:
c:\>gem update --system --source http://onestepback.org/betagems
Upgrading RubyGems...
Updating Gem source index for: http://onestepback.org/betagems
Attempting remote upgrade of rubygems-update
Attempting remote installation of 'rubygems-update'
Successfully installed rubygems-update-0.8.10.101
Updating version of RubyGems to 0.8.10.101
Installing RubyGems 0.8.10.101
---> bin
<--- bin
---> lib
---> lib/rubygems
<--- lib/rubygems
<--- lib
---> bin
adjusting shebang: gem_mirror
setup.rb:492:in `unlink': Permission denied - gem_mirror (Errno::EACCES)
        from setup.rb:492:in `move_file'
        from setup.rb:1145:in `adjust_shebang'
        from setup.rb:1136:in `open'
        from setup.rb:1136:in `adjust_shebang'
        from setup.rb:1128:in `setup_dir_bin'
        from setup.rb:1127:in `each'
        from setup.rb:1127:in `setup_dir_bin'
        from setup.rb:1321:in `__send__'
         ... 7 levels...
        from setup.rb:883:in `exec_setup'
        from setup.rb:704:in `invoke'
        from setup.rb:674:in `invoke'
        from setup.rb:1352
RubyGems system software updated

*** Second Run
c:\>gem --debug --backtrace update --system --source
http://onestepback.org/betagems
Exception `Errno::ENOENT' at
c:/bin/ruby/lib/ruby/site_ruby/1.8/rubygems/config_file.rb:12 - No
such file or directory -
 C:\Documents and Settings\Admin/.gemrc
Upgrading RubyGems...
Attempting remote upgrade of rubygems-update
Attempting remote installation of 'rubygems-update'
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - c:/bin/ruby/lib/ruby/gems/1.8/gem
s/rubygems-update-0.8.10.101
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - .
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - .
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - .
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - .
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - .
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - .
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - .
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - bin
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - bin
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - bin
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - bin
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - bin
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - bin
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - doc
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - doc
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - examples/application
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - examples/application/bin
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - examples/application/lib
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - gemspecs
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - gemspecs
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - gemspecs
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - gemspecs
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - gemspecs
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - gemspecs
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - gemspecs
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - gemspecs
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - gemspecs
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - gemspecs
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - gemspecs
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - lib
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - lib
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - lib
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - lib/rubygems
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - lib/rubygems
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - lib/rubygems
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - lib/rubygems
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - lib/rubygems
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - lib/rubygems
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - lib/rubygems
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - lib/rubygems
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - lib/rubygems
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - lib/rubygems
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - lib/rubygems
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - lib/rubygems
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - lib/rubygems
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - lib/rubygems
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - lib/rubygems
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - lib/rubygems
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - lib/rubygems
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - lib/rubygems
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - lib/rubygems
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - lib/rubygems
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - lib/rubygems
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - lib/rubygems
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - lib/rubygems
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - lib/rubygems
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - lib/rubygems
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - lib/rubygems
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - pkgs/sources
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - pkgs/sources/lib
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - redist
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - scripts
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - scripts
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - scripts
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - scripts
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - scripts
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test/data/one
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test/data/one
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test/data/one
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test/data/one/lib
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test/data/legacy
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test/data/legacy
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test/data/lib
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test/mock/gems/gems/sources-0.0.1
/lib
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test/mock/gems/specifications
Exception `Errno::EEXIST' at c:/bin/ruby/lib/ruby/1.8/fileutils.rb:212
- File exists - test/fake_certlib
Successfully installed rubygems-update-0.8.10.101
Updating version of RubyGems to 0.8.10.101
Installing RubyGems 0.8.10.101
---> bin
<--- bin
---> lib
---> lib/rubygems
<--- lib/rubygems
<--- lib
---> bin
adjusting shebang: gem_mirror
<--- bin
---> lib
---> lib/rubygems
<--- lib/rubygems
<--- lib
rm -f InstalledFiles
---> bin
mkdir -p c:/bin/ruby/bin/
install gem c:/bin/ruby/bin/
install gemwhich c:/bin/ruby/bin/
install gem_mirror c:/bin/ruby/bin/
install gem_server c:/bin/ruby/bin/
install generate_yaml_index.rb c:/bin/ruby/bin/
install update_rubygems c:/bin/ruby/bin/
<--- bin
---> lib
mkdir -p c:/bin/ruby/lib/ruby/site_ruby/1.8/
install gemconfigure.rb c:/bin/ruby/lib/ruby/site_ruby/1.8/
install rubygems.rb c:/bin/ruby/lib/ruby/site_ruby/1.8/
install ubygems.rb c:/bin/ruby/lib/ruby/site_ruby/1.8/
---> lib/rubygems
mkdir -p c:/bin/ruby/lib/ruby/site_ruby/1.8/rubygems
install builder.rb c:/bin/ruby/lib/ruby/site_ruby/1.8/rubygems
install cmd_manager.rb c:/bin/ruby/lib/ruby/site_ruby/1.8/rubygems
install command.rb c:/bin/ruby/lib/ruby/site_ruby/1.8/rubygems
install config_file.rb c:/bin/ruby/lib/ruby/site_ruby/1.8/rubygems
install custom_require.rb c:/bin/ruby/lib/ruby/site_ruby/1.8/rubygems
install dependency_list.rb c:/bin/ruby/lib/ruby/site_ruby/1.8/rubygems
install deployment.rb c:/bin/ruby/lib/ruby/site_ruby/1.8/rubygems
install doc_manager.rb c:/bin/ruby/lib/ruby/site_ruby/1.8/rubygems
install format.rb c:/bin/ruby/lib/ruby/site_ruby/1.8/rubygems
install gem_commands.rb c:/bin/ruby/lib/ruby/site_ruby/1.8/rubygems
install gem_openssl.rb c:/bin/ruby/lib/ruby/site_ruby/1.8/rubygems
install gem_runner.rb c:/bin/ruby/lib/ruby/site_ruby/1.8/rubygems
install installer.rb c:/bin/ruby/lib/ruby/site_ruby/1.8/rubygems
install loadpath_manager.rb c:/bin/ruby/lib/ruby/site_ruby/1.8/rubygems
install old_format.rb c:/bin/ruby/lib/ruby/site_ruby/1.8/rubygems
install open-uri.rb c:/bin/ruby/lib/ruby/site_ruby/1.8/rubygems
install package.rb c:/bin/ruby/lib/ruby/site_ruby/1.8/rubygems
install remote_installer.rb c:/bin/ruby/lib/ruby/site_ruby/1.8/rubygems
install rubygems_version.rb c:/bin/ruby/lib/ruby/site_ruby/1.8/rubygems
install security.rb c:/bin/ruby/lib/ruby/site_ruby/1.8/rubygems
install source_index.rb c:/bin/ruby/lib/ruby/site_ruby/1.8/rubygems
install specification.rb c:/bin/ruby/lib/ruby/site_ruby/1.8/rubygems
install timer.rb c:/bin/ruby/lib/ruby/site_ruby/1.8/rubygems
install user_interaction.rb c:/bin/ruby/lib/ruby/site_ruby/1.8/rubygems
install validator.rb c:/bin/ruby/lib/ruby/site_ruby/1.8/rubygems
install version.rb c:/bin/ruby/lib/ruby/site_ruby/1.8/rubygems
<--- lib/rubygems
<--- lib

As of RubyGems 0.8.0, library stubs are no longer needed.
Searching $LOAD_PATH for stubs to optionally delete (may take a while)...
...done.
No library stubs found.

  Successfully built RubyGem
  Name: sources
  Version: 0.0.1
  File: sources-0.0.1.gem
RubyGems system software updated
removing C:/DOCUME~1/Admin/LOCALS~1/Temp/open-uri2540.0...done

c:\>gem env
Rubygems Environment:
  - VERSION: 0.8.10.101 (0.8.10.101)
  - INSTALLATION DIRECTORY: c:/bin/ruby/lib/ruby/gems/1.8
  - GEM PATH:
     - c:/bin/ruby/lib/ruby/gems/1.8
  - REMOTE SOURCES:
     - http://gems.rubyforge.org


On 7/10/05, Jim Weirich <jim at weirichhouse.org> wrote:
> I have a release candidate for the next RubyGems version available at
> http://onestepback.org/betagems.  I'm having problems using the gem update
> command on windows to get it installed.  Would someone else like to give it a
> try just in case it is my local windows box that is messed up?  The command
> is:
> 
>    gem update --system --source http://onestepback.org/betagems
> 
> This /should/ install version 0.8.10.100.  My box is giving me a permission
> error when updating the shebang lines.
> 
> Thanks.
> 
> Meanwhile I'll continue to debug on my windows box. (blech)
> 
> --
> -- Jim Weirich    jim at weirichhouse.org     http://onestepback.org
> -----------------------------------------------------------------
> "Beware of bugs in the above code; I have only proved it correct,
> not tried it." -- Donald Knuth (in a memo to Peter van Emde Boas)
> _______________________________________________
> Rubygems-developers mailing list
> Rubygems-developers at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rubygems-developers
>



More information about the Rubygems-developers mailing list