[Rubygems-developers] Feature request: don't die on rdoc

Assaph Mehr assaph at gmail.com
Thu Jul 7 19:04:25 EDT 2005


Hi all, 

When attempting an upgrade of the rails gems, gems keeps chocking of
rdoc (see transcript below).

Would it be possible to treat rdoc errors as not fatal and continue
with the rest of the installation? I'd attempt a patch but my current
free time is rapidly approaching the imaginary numbers scale.

Cheers,
Assaph


c:\>gem up
Upgrading installed gems...
Updating Gem source index for: http://gems.rubyforge.org
Attempting remote upgrade of actionmailer
Attempting remote installation of 'actionmailer'
Install required dependency actionpack? [Yn]
Install required dependency activesupport? [Yn]
Successfully installed actionmailer-1.0.0
Successfully installed actionpack-1.9.0
Successfully installed activesupport-1.1.0
Installing RDoc documentation for actionmailer-1.0.0...
ERROR:  While executing gem ... (NoMethodError)
    undefined method `as_href' for nil:NilClass

c:\>gem up
Upgrading installed gems...
Attempting remote upgrade of actionwebservice
Attempting remote installation of 'actionwebservice'
Install required dependency activerecord? [Yn]
Successfully installed actionwebservice-0.8.0
Successfully installed activerecord-1.11.0
Installing RDoc documentation for actionwebservice-0.8.0...
Installing RDoc documentation for activerecord-1.11.0...
ERROR:  While executing gem ... (NoMethodError)
    undefined method `as_href' for nil:NilClass

c:\>gem up
Upgrading installed gems...
Updating Gem source index for: http://gems.rubyforge.org
Attempting remote upgrade of builder
Attempting remote installation of 'builder'
Successfully installed builder-1.2.4
Installing RDoc documentation for builder-1.2.4...
Attempting remote upgrade of cmdparse
Attempting remote installation of 'cmdparse'
Successfully installed cmdparse-1.0.5
Installing RDoc documentation for cmdparse-1.0.5...
Attempting remote upgrade of color-tools
Attempting remote installation of 'color-tools'
Successfully installed color-tools-1.2.0
Installing RDoc documentation for color-tools-1.2.0...
Attempting remote upgrade of rails
Attempting remote installation of 'rails'
Successfully installed rails-0.13.0
Gems: [builder, cmdparse, color-tools, rails] updated

c:\>ruby -v
ruby 1.8.2 (2004-12-25) [i386-mswin32]

c:\>gem env
Rubygems Environment:
  - VERSION: 0.8.10 (0.8.10)
  - INSTALLATION DIRECTORY: c:/bin/ruby/lib/ruby/gems/1.8
  - GEM PATH:
     - c:/bin/ruby/lib/ruby/gems/1.8
  - REMOTE SOURCES:
     - http://gems.rubyforge.org



More information about the Rubygems-developers mailing list