[Rubygems-developers] Ruby Gem Install Problem on OSX

Jason Savidge it at onestopent.com.au
Mon Jan 10 12:59:28 EST 2005


Hi,
I am trying to install Ruby and Rails so I can begin testing it for web
development on OSX. I seem to have gotten Ruby installed and Rubygems but I
get the following error when trying to get to next step of installing rails.
I installed 1.8 as specified for OSX which leaves 1.6 still on the OSX
system. It seems to be looking towards the 1.6 default install of ruby for
some reason.

Thanks for any help you can give.

Jason

------------------------------------------------------------------
stevieray:~/desktop $ gem install rails
/usr/local/lib/ruby/site_ruby/1.6/rubygems.rb:353:in `require':
/usr/local/lib/ruby/site_ruby/1.6/rubygems/specification.rb:312: return
appeared outside of method (SyntaxError)
      return @default_executable if @default_executable
                                   ^
/usr/local/lib/ruby/site_ruby/1.6/rubygems/specification.rb:315: return
appeared outside of method
      return @executables.first if @executables.size == 1
                                  ^
        from /usr/local/lib/ruby/site_ruby/1.6/rubygems.rb:353
        from /usr/bin/gem:3:in `require'
        from /usr/bin/gem:3




More information about the Rubygems-developers mailing list