[Rubygems-developers] Fwd: Problems with Rails' gemspec and with RiubyGems

Chad Fowler chad at chadfowler.com
Mon Jan 31 07:11:24 EST 2005

Can someone on the list take a look at this?  I'm heading out of town 
and will be useless for the next week.  Sounds like this one is a big 
enough deal that it should get some attention before then.


Begin forwarded message:

> From: "Curt Hibbs" <curt at hibbs.com>
> Date: 30 January 2005 8:35:15 PM EST
> To: "Chad Fowler" <chad at chadfowler.com>
> Cc: "David Heinemeier Hansson" <david at loudthinking.com>, "Curt Hibbs" 
> <curt at hibbs.com>
> Subject: RE: Problems with Rails' gemspec and with RiubyGems
> Chad Fowler wrote:
>> If you don't mind, I'm going to send this to the rubygems-developers
>> list . I'm headed out of town tomorrow and will be out of touch for
>> most of the week.
> Sure, the only reason I sent this direct was I wanted to make sure it 
> got
> attention.
>> FWIW, on the Mac, I was able to install rails 0.9.4 without a problem.
>> I wonder if it's a Windows-specific problem?
> I can install 0.9.4 on windows too without any problem, too. Its just 
> that
> it won't work because it installs activerecord 1.6.0 instead of 
> activerecord
> 1.5.0, and it installs actionpack 1.4.0 instead of 1.3.0. This part is 
> not a
> RubyGems problem, its a problem with the rails gemspec.
> The part that I think may be a RubyGems problem is that if I first 
> install
> activerecord 1.4.0 and actionpack 1.3.0, and then I try to install 
> rails
> 0.9.4, somehow rails 0.9.5 gets installed (in addition to rails 0.9.4).
> Curt
>> On 30-Jan-05, at 1:01 PM, Curt Hibbs wrote:
>>> There is a problem with Rails' gemspec that makes it impossible to
>>> install
>>> an older version of using the simple command:
>>>   gem install rails -v
>>> Please see my text below for more details. But the bottom line is 
>>> that
>>> doing
>>> this installs rails-0.9.4 and the latest versions of activerecord and
>>> actionpack. Unfortunately, this combination is incompatible and 
>>> causes
>>> some
>>> bizarre problems (see the link to the onlamp feedback). I think the
>>> rails
>>> package should specify specific versions of the other packages (the
>>> ones it
>>> was tested with, released together, and known to work).
>>> Further, due to some problem in RubyGems, I can't even manually 
>>> install
>>> specific versions of activerecord, actionpack, and rails (see 
>>> below), I
>>> always end up with the latest version of all packages installed. It
>>> seems to
>>> me that this is a bug in RubyGems.
>>> Can you guys please look into this?
>>> Thanks,
>>> Curt
>>> -----Original Message-----
>>> From: help at oreillynet.com [mailto:help at oreillynet.com]
>>> Sent: Sunday, January 30, 2005 11:27 AM
>>> To: curt at hibbs.com; chromatic at oreilly.com
>>> Subject: New talkback on "Rolling with Ruby on Rails"
>>> A new message was posted to your article or weblog!
>>> Rolling with Ruby on Rails
>>> http://www.oreillynet.com/pub/a/onlamp/2005/01/20/rails.html?
>>> page=last#threa
>>> d
>>> Subject: Not working as advertised
>>> Author: curth
>>> Text of message:
>>> Part of the problem (at least the part I understand) has to do with
>>> the fact
>>> that the RubyGems package named "rails" is composed of some glue code
>>> that
>>> binds together three other, independent RubyGems packages named
>>> "activerecord", "actionpack" and "actionmailer.
>>> And, for example, the rails-0.9.4 package says it depends on the
>>> packages
>>> activerecord-1.5.0 or greater, actionspack-1.3.0 or greater, and
>>> actionmailer-0.6.0 or greater. Rails-0.9.5 uses more recent versions
>>> of all
>>> three packages. The problem here is with the "or greater" part.
>>> When you "gem uninstall rails" it only removes the rails package, and
>>> not
>>> the others. When you say "gem install rails -v 0.9.4" it happily
>>> installs
>>> rails-0.9.4, but keeps using the more recent versions of the other
>>> packages
>>> because the "or greater" part of the dependency tells RubyGems those
>>> packages work fine rails-0.9.4. The problem is that they don't, and
>>> cause
>>> the weird URLs that you are seeing. This has got to be an unforseen
>>> bug in
>>> Rails' gemspec, and I need to post a bug report for this.
>>> To make matters worse, you can't even go back to rails-0.9.4 by 
>>> trying
>>> to
>>> install the desired packages manually. I tried to do this last night:
>>> <pre>
>>>   gem install activerecord -v 1.5.0
>>>   gem install actionpack -v 1.3.0
>>>   gem install actionmailer -v 0.6.0
>>>   gem install rails -v 0.9.4
>>> </pre>
>>> When installing rails-0.9.4 RubyGems should notice that all the other
>>> needed
>>> packages are already installed and just install the rails package.
>>> Unfortunately, it does install rails-0.9.4 and then proceeds to 
>>> install
>>> rails-0.9.5 and the latest version of all the other packages. This 
>>> has
>>> got
>>> to be a bug in the RubyGems package manager, and I will report this 
>>> as
>>> well.
>>> But, the bottom line is that there is currently no way to correctly
>>> install
>>> anything but the latest version of rails, and the uninstall/reinstall
>>> instructions that I gave earlier not only don't work, but also cause
>>> bizarre
>>> strangeness due to these unintended incompatibilities.
>>> I would recommens that you wipe out everything and reinstall from a
>>> clean
>>> slate, stick with rails-0.9.5 and <i>do not</i> attempt to install an
>>> older
>>> version.
>>> --
>>> No virus found in this incoming message.
>>> Checked by AVG Anti-Virus.
>>> Version: 7.0.300 / Virus Database: 265.7.4 - Release Date: 1/25/2005
>> --
>> No virus found in this incoming message.
>> Checked by AVG Anti-Virus.
>> Version: 7.0.300 / Virus Database: 265.7.4 - Release Date: 1/25/2005
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: text/enriched
Size: 5729 bytes
Desc: not available
Url : http://rubyforge.org/pipermail/rubygems-developers/attachments/20050131/f8464ec5/attachment.bin

More information about the Rubygems-developers mailing list