[Rubygems-developers] Ruby doesn't see my Gems (n00b assistance) - fixed!

Peter Marreck lumbergh at gmail.com
Fri Jan 28 14:03:25 EST 2005


I fixed the issue by starting from scratch and following the
directions on this page to install all the parts via DarwinPorts:
http://www.sateh.com/projects/sateh/wiki/InstallingRailsOnOSX
This worked out well anyway as DarwinPorts had a later port of Ruby
(1.8.2) than Fink did (1.8.0).

Mistakes I made along the way (for posterity):
1) Including an "export RUBYOPT=rubygems" in my .profile would
continually result in an odd "not found- ubygems" error (missing "r"
and all) during ruby compilation, aborting compilation attempts.
Removing this line fixed that issue. (I had to put it back later in
order for Ruby to see gems. Thanks for that tip!)
2) You have to compile things like sqlite separately before you add
the gem for it (n00b error). Unfortunately, the error you get when you
try to do the reverse is not very informative ("ERROR: Failed to build
gem native extension.") I figured this out by getting the gist that it
was seeking a header file, and proceeded to smack my forehead with a
"header files are installed with the library itself! it must not be
doing so" remark.
3) The link above has an unnecessary step- it's not necessary to
create a "darwinports" directory yourself, the install does that for
you. So I had a "~/darwinports/darwinports/etc.." directory ugliness I
wanted to fix, because I'm anal like that. But if you happen to move
the "darwinports" directory somewhere else, you will get all kinds of
errors (surprise, not). Googling the error revealed that the location
is stored in a config file called "sources.conf", and I had to rebuild
my locate.updatedb first before I could find out where that file was
put (it was not in the location I found via googling). But it's there
(right in /usr/local/etc/ports/sources.conf)... and changing the path
fixed that.
4) Fixed my PATH to prefer the /usr/local/bin version of Ruby vs. the
standard OS X-installed one.

So now it works!

I'm OK with struggling through these issues for the time being (as
long as I can continue to figure them out), but I wish that someone
would finish an OS X packaged install for these things =)

Regards,
Peter

On Thu, 27 Jan 2005 17:19:45 -0000 (UTC), Jim Weirich
<jim at weirichhouse.org> wrote:

> Are you enabling RubyGems by either the -rubygems command line option or
> the RUBYOPT=rubygems environment variable (see
> http://onestepback.org/articles/rubygemsfacets/demoreview2.html)

-- 
I was RAISED on the command line... beeotch.
http://marreck.com/littlegeek.jpg
"What is in my heart must come out and so I write it down."
Beethoven


More information about the Rubygems-developers mailing list