[Rubygems-developers] RubyGems Problem with "Rolling with Ruby onRails"

Assaph Mehr assaph at gmail.com
Wed Jan 26 17:12:39 EST 2005

On Wed, 26 Jan 2005 21:25:52 -0000 (UTC), Jim Weirich
<jim at weirichhouse.org> wrote:
> Curt Hibbs said:
> > The users whose message is below, is trying to install Rails behind an
> > authenticating proxy. How do you do this with RubyGems?
> Rubygems uses open-uri to access remote gems.  AFAIK, open-uri does not
> support authenticating proxies.
> However, I did see on the Rails list someone replied with a workaround.

There was indeed patch for open-uri by Neil Kohl posted here a couple
of weeks ago (let me know if you can't find a copy). It supports
proxies with basic authentication only, so will not work with MS
proxies that do authentication through NTLM.

I found a local proxy that'll do the NTLM authentication with the main
proxy (http://apserver.sourceforge.net/). I have managed to get ruby
scripts to work through it using both net/http and open-uri, but the
gem command times-out. I did not have the chance yet to find out why.


More information about the Rubygems-developers mailing list