[Rubygems-developers] /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in `require__': No such file to load -- zlib

Andrew Cranson cranky at transnexis.com
Mon Aug 1 14:27:13 EDT 2005


> Some OS repackagers break Ruby. Debian used to be the worst culprit,
> but you'll want to make sure you have zlib and ruby-zlib (or something
> like that) installed, as these *are* parts of core Ruby but some folks
> don't see fit to install them with the core Ruby language.
>
> -austin

Thank you for responding Austin. I compiled and installed ruby, fcgi and
mod_fastcgi from source rather than using RPM's. I have zlib RPM installed.
Would I need to install ruby-zlib manually from source, or should it be 
part of
the ruby installation?

Thanks,



More information about the Rubygems-developers mailing list