[Rubygems-developers] /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in `require__': No such file to load -- zlib

Andrew Cranson cranky at transnexis.com
Mon Aug 1 10:55:09 EDT 2005


Hi,

When installing rubygems I get:

/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in `require__':
No such file to load -- zlib
(LoadError)
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/package.rb:9
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require__'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/builder.rb:1
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require__'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:61:in `manage_gems'
         ... 7 levels...
        from setup.rb:887:in `exec_install'
        from setup.rb:705:in `invoke'
        from setup.rb:674:in `invoke'
        from setup.rb:1352

Do you have any ideas what can be causing it? This is with rubygems-0.8.11, I've
tried a few things but can't seem to get it working.

Andrew



More information about the Rubygems-developers mailing list