[Rubygems-developers] Bug: cached gem not overwritten

Jim Weirich jim at weirichhouse.org
Sun Sep 12 13:25:03 EDT 2004

Chad Fowler wrote:
> On Sep 12, 2004, at 2:20 AM, Jim Weirich wrote:
>> Gavin Sinclair wrote:
>>> If you install a gem (say blah-0.1.gem) several times, the file
>>> cache/blah-0.1.gem is only written the first time.  AFAIC that's a
>>> bug, but I want conformation before fixing it.
>> Dang, you rule!   I was having trouble getting executables to work 
>> with 0.8.0 and reinstalled 0.7.0.  But when I tried to install on a 
>> remote system I kept getting errors in the gem specification.  
>> Confused, I decided to read my mail and found your message.  So I 
>> manually cleansed the gem directory and everything worked (well ... 
>> gems work ... still working the bugs out of my app).
>>> This needn't affect the 0.8.0 release, anyway.  It's a marginal issue,
>>> and could be fixed later for 0.8.1 or something.
>> But, I am still having problems with the executables.  The executable 
>> stub still tries to load "bin/app" and doesn't find it.  I haven't had 
>> time to look into, but I think it is a show stopper.  Sorry.
> Can you send an example gem that isn't working?

Ok, it was happening to me all night last night and I was getting really 
frustrated.  But now everything seems to be ok.  I've been switching 
back and forth between RubyGems CVS and 0.7.0 and must have gotten 
something goofed up.  Let's attribute this one to breaking the "NO 

Sorry for the alarm.

-- Jim Weirich    jim at weirichhouse.org     http://onestepback.org
"Beware of bugs in the above code; I have only proved it correct,
not tried it." -- Donald Knuth (in a memo to Peter van Emde Boas)

More information about the Rubygems-developers mailing list