[Rubygems-developers] Bug: cached gem not overwritten

Chad Fowler chad at chadfowler.com
Sun Sep 12 09:40:53 EDT 2004


On Sep 12, 2004, at 2:20 AM, Jim Weirich wrote:

> Gavin Sinclair wrote:
>> If you install a gem (say blah-0.1.gem) several times, the file
>> cache/blah-0.1.gem is only written the first time.  AFAIC that's a
>> bug, but I want conformation before fixing it.
>
> Dang, you rule!   I was having trouble getting executables to work 
> with 0.8.0 and reinstalled 0.7.0.  But when I tried to install on a 
> remote system I kept getting errors in the gem specification.  
> Confused, I decided to read my mail and found your message.  So I 
> manually cleansed the gem directory and everything worked (well ... 
> gems work ... still working the bugs out of my app).
>
>> This needn't affect the 0.8.0 release, anyway.  It's a marginal issue,
>> and could be fixed later for 0.8.1 or something.
>
> But, I am still having problems with the executables.  The executable 
> stub still tries to load "bin/app" and doesn't find it.  I haven't had 
> time to look into, but I think it is a show stopper.  Sorry.
>

Can you send an example gem that isn't working?

Thanks,
Chad



More information about the Rubygems-developers mailing list