[Rubygems-developers] Bug: cached gem not overwritten

Jim Weirich jim at weirichhouse.org
Sun Sep 12 02:20:13 EDT 2004


Gavin Sinclair wrote:
> If you install a gem (say blah-0.1.gem) several times, the file
> cache/blah-0.1.gem is only written the first time.  AFAIC that's a
> bug, but I want conformation before fixing it.

Dang, you rule!   I was having trouble getting executables to work with 
0.8.0 and reinstalled 0.7.0.  But when I tried to install on a remote 
system I kept getting errors in the gem specification.  Confused, I 
decided to read my mail and found your message.  So I manually cleansed 
the gem directory and everything worked (well ... gems work ... still 
working the bugs out of my app).

> This needn't affect the 0.8.0 release, anyway.  It's a marginal issue,
> and could be fixed later for 0.8.1 or something.

But, I am still having problems with the executables.  The executable 
stub still tries to load "bin/app" and doesn't find it.  I haven't had 
time to look into, but I think it is a show stopper.  Sorry.

-- 
-- Jim Weirich    jim at weirichhouse.org     http://onestepback.org
-----------------------------------------------------------------
"Beware of bugs in the above code; I have only proved it correct,
not tried it." -- Donald Knuth (in a memo to Peter van Emde Boas)


More information about the Rubygems-developers mailing list