[Rubygems-developers] Release 0.8.0? (Was: Rubygems update script updated on rubyforge)

Mauricio Fernández batsman.geo at yahoo.com
Sat Sep 11 05:27:33 EDT 2004

On Thu, Sep 09, 2004 at 10:01:46PM -0400, Gavin Sinclair wrote:
> Possible solutions: allow the following:
>   A) require 'extensions/string', '= 0.3'
>   B) require_gem 'extensions/string', '= 0.3'
>   C) give up on such shortcuts

(B) is somewhat nicer to other repackagers because it's easier to
grep for.  Additionally, RubyGems' isn't the only way to handle library
versioning, so IMHO require_gem is clearer.

Running Debian GNU/Linux Sid (unstable)
batsman dot geo at yahoo dot com

More information about the Rubygems-developers mailing list